Metasploit 3.0 e MacOSX 10.4.9

*update* 9 Maggio 23:05: la coincidenza e` impressionante.
Nello stesso momento (quasi, non ho fatto i conti di chi prima e chi dopo) Richard Bejtlich (TaoSecurity) scriveva piu` o meno dello stesso argomento. E commentando gli stessi problemi!

Questa sera ho provato a dare uno sguardo a Metasploit sul Mac: l’ultima versione con cui avevo giocato era una delle beta della 3.0, e avevo ancora il Mac PPC.
Sono su un Mac aggiornato alla ultima release (10.4.9 / Intel), ruby dice di essere

ruby 1.8.2 (2004-12-25) [universal-darwin8.0]

ma visto che mi sono guardato bene dal leggere la documentazione, all’esecuzione della console con interfaccia web di Metasploit sono stato accolto da questo messaggio:

./script/../config/boot.rb:18:in `require': No such file to load -- rubygems (LoadError)
from ./script/../config/boot.rb:18
from ./script/server:2:in `require'
from ./script/server:2
from ./msfweb:82:in `load'
from ./msfweb:82

dal che ne ho brillantemente dedotto che non ci fosse rubygems installato.
Ora, si presentavano due opzioni:

  • installare rubygems dai ports (MacPorts), il che si porta dietro altre cosette fastidiose come tutto il Perl (che non ho nessuna intenzione di compilare un’altra volta)
  • installare il tutto dritto sulla parte di ruby di sistema

La seconda opzione e` decisamente piu` rapida.

Quindi:

  • si va qui, si scarica l’ultima versione disponibile (in questo caso, la 0.9.2)
  • si spacchetta e si installa il tutto:

    tar xvfz rubygems-0.9.2.tgz
    cd rubygems-0.9.2
    ruby setup.rb
  • (abbiamo rubygems installato, ora funziona il comando gem)

  • ora proviamo ad installare Ruby On Rails come dice la documentazione di Metasploit (che nel frattempo abbiamo letto)

    gem install -v1.2.2 rails

    per scoprire che la 1.2.2 non e` piu` disponibile. Quindi installiamo l’ultima.

  • Proviamo ottimisti a lanciare ./msfweb, che protesta vivacemente dicendo

    Cannot find gem for Rails ~>1.2.2.0:
    Install the missing gem with 'gem install -v=1.2.2 rails', or change environment.rb to define RAILS_GEM_VERSION with your desired version.

    Ok, scopriamo quale versione di RoR mi ha installato (gem list, e si cerca rails) e andiamo a sistemare il file

    ./data/msfweb/config/environment.rb

    mettendo la versione giusta di RoR:
    RAILS_GEM_VERSION = '1.2.3' unless defined? RAILS_GEM_VERSION

Ahh. Enjoy.

$ ./msfweb

[*] Starting msfweb v3.0 on http://127.0.0.1:55555/

=> Booting WEBrick...
=> Rails application started on http://127.0.0.1:55555
=> Ctrl-C to shutdown server; call with --help for options
[2007-05-08 23:40:02] INFO WEBrick 1.3.1
[2007-05-08 23:40:02] INFO ruby 1.8.2 (2004-12-25) [universal-darwin8.0]
[2007-05-08 23:40:02] INFO WEBrick::HTTPServer#start: pid=8915 port=55555

L’interfaccia e` davvero “una fiqata pazzesca“(C), moooolto webduepuntozero.

Note to self: oggettivamente ho impiegato di piu` a scrivere questo post che a sistemare le cose. Bisogna che capisca se ne vale la pena.

Author: zen

Geek of all trades, having fun with *NIX, the Internet and computer security since 1995.

4 thoughts on “Metasploit 3.0 e MacOSX 10.4.9”

  1. Si` che l’ho letta (dopo), ma dice:

    Finally, use the “gems” command to install the correct version of Rails:
    root# gem install -v=1.2.2 rails

    ma come avrai visto la 1.2.2 non esiste piu`! :)

Leave a Reply

Your email address will not be published. Required fields are marked *

This site uses Akismet to reduce spam. Learn how your comment data is processed.